Project DNA2 Assembly and Analysis of a cloned DNA fragment using Snapgene				


Objective:	To learn to use PC‑based, DNA analysis software to:

Input DNA and protein sequences, search GenBank and other databases for sequence homology, download sequence data from public databases, create restriction enzyme site maps from sequence data, translate DNA sequence to create predicted protein sequences, and display the analyzed data. 

Storage of Data:  Although in a real project some data will be copied and placed in the lab book, the large volume of paper generated by DNA analysis is usually stored in a binder or archived as digital data. In our lab all files are retained on the computer and archived onto CD-R (now DVD-R). 

For this class please save data in directories organized by project. There will be no hard copy files to be saved for this class but you may print them out for yourself if you wish. Instead of printing the files onto paper, you will create specific computer files. The required data is listed at the end of each project.

A tip on saving DNA and Protein sequences: I save individual DNA sequences as GenBank (*.gb) format and DNA assemblies are SeqTrace projects (*.str) . Trace files are *.abi or *.ab1. That way you can tell them apart on the computer.  DNA and protein sequences can also be saved as text files (*.txt). For instance, in project D1 I would have GenBank files H600‑T3.gb and H600‑T7.gb each containing an individual file and H600.str containing the SeqTrace DNA assembly.  H600 con.gb would be the consensus sequence. 
[We won’t be assembling H600 with SeqTrace this time]

For more information about sequence file types, software and other bioinformatic topics please visit my Bioinformatics web page http://www.blewetts.net/bioinformatics.html.

Exercise 1	The pH600 Fragment

The pH600 clone is a small, HindIII fragment of viral DNA (BaCMV OCOM4-37) cloned into the vector pBluescript II SK(+). The sequencing facility has sent two sequences to you. One sequence was obtained using the T3 primer and the other sequence was generated using the T7 primer.

Objective:	To derive the complete sequence of both strands of the fragment, construct a restriction map identifying the sites of all the unique enzymes in the fragment, search GenBank for similar sequences, download any 4 of these sequences to your hard drive.

Procedure:	There are several different ways to accomplish these tasks. We will assemble the DNA using manual methods and SnapGene Viewer. These traces do not contain weighted data and cannot be assembled using SeqTrace. However, other commercial assembly programs or free programs such as GeneStudio or GAP4 program of Staden can be used to assemble them. 

There are three datasets available for this project, B393, H600 or H637. In each zipped dataset are the sequence and trace files needed for your assignments. There are two trace files that have the ending *.ab1. 

Creating a DNA sequence file from a trace file using SnapGene Viewer
ABI trace files contain a great deal of data. There is the chromatogram (trace) itself, plus information  about the machine that produced the trace, dates and also the DNA sequence derived from the trace. We are going to use SnapGene Viewer to see the information and chromatogram and to cut the useable DNA sequence out of the trace.

Using SnapGene Viewer to open the H600-T7.ab1 trace file. A viewable chromatogram with uneditable (above) sequence will appear. We will call this the Forward Primer trace.
You can see all the sequence data by clicking the Chromatogram Data button below the sequence. Another box will open on the sequence tab. This is the sequence as “called” by the ABI machine. You can copy this sequence as text to any other program. 
Click the parameters tab and see more information that is contained in the trace file.
Go back to the DNA sequence using the Sequence tab,select all the text and use control-C to copy it to the clipboard
-sometimes Control-C doesn’t work. Select all the text then right click on it and select copy
Open Notepad or any simple text editor and paste the sequence data into a file.
-you can use word or other word processor programs if you can remember to save your sequence as a simple text tile (*.txt)
Save the File as H600-T7.txt

The construct pH600 is a small HindIII fragment of BaCMV cloned into pBlueScript II SK (+). The fragment is <200 bp long. We need to cut the useable data out of the long sequence. The trace begins in the vector, reads through the MCS and into the insert, through the insert, through the other side of the MCS and into the vector proper. We know that we can read through the MCS to the HindIII site (AAGCTT) where the insert sequence  should begin. After the second HindIII site we should start to read the MCS again. The useable sequence are the bases from the first HindIII to the second. The sites are included because they were present in the BaCMV DNA. We can use our simple text editor program to cut away the usuable data. 

Open find (Control-C) and type in the HindIII recognition sequence, AACGTT
Find this sequence in the text.
See if you can find a second sequence.
-The DNA sequence between these two sites should be the clone sequence.
You can clip away the undesired MCS sequence at the 5’ end of the sequence by selecting and deleting it.
1. Similarly you can clip away the undesired MCS sequence (or low quality trace data) at the 3’ end of the sequence by selecting and deleting it. Save your sequence as a text file. Close SnapGene.

This only works when your trace file information is very good. It’s usually better to work with the chromatogram itself, as you can see the sequence quality. 

2. We will extract the “good” sequence from trace H600-T3.ab1 which is the Reverse Primer trace using the chromatogram.
3. Open trace H600-T3.ab1 in SnapGene.
-note the initial 5’ end of the trace isn’t readable. A trace is usually readable about 10 – 20 bp from the primer binding site.
4. Look at your map of pBluescript II SK (+) and find the T3 primer binding site and the HindIII site in the MCS.
5. In SnapGene, scroll until you find the HindIII site, AAGCTT, around bp 85.
6. Read leftward, 5’ direction, from the HindIII site and match it to the MCS sequence.
7. Read rightward, 3’ direction, from the HindIII site and make sure it doesn’t match the MCS.
-if it matches the MCS then the clone doesn’t have a HindIII insert
8. You can search the sequence to find HindIII sites. Select Control-F (or Edit > Find), type the HindIII sequence into the box, AAGCTT and hit next on the far right
9. This should take you to the first HindIII site, bases 85 – 90.
10. Hit next again to search for a second HindIII site.
11. You should see a site at bp 271.
12. You can select the sequence at the top of the trace and copy the sequence.
13. Paste this sequence into a text editor and save it as H600-T3.txt.
14. In SnapGene, with the sequence still selected, select Edit > Copy Reverse Complement
15. Open your text editor and paste this sequence in and save it as H600-T3comp.txt
-The H600-T3 sequence is the complementary version of H600-T7. We want to get the complementary form of H6-00-T3 for the alignment.
16. Another way to get the complementary sequence is to open the H600-T3.ab1 trace in SnapGene.
17. To get the complementary view select View > Flip Sequence
18. Generate the H600-T2 complementary sequence using the steps above and save it as H600-T3comp.txt
19. Close SnapGene Viewer but keep the two text files, H600-T7.txt and H600-T3comp.txt open, they will be needed in the next section

20. Normally we would assemble the two trace files to form a consensus sequence. However, this trace data does not contain weights so SeqTrace will not work. We will instead compare the trace files using Clustall, a widely used alignment program. 
21. We will use a web-based version of Clustall (http://www.clustal.org/) called Clustal Omega so there is no need to install it on your computer. However, many  DNA analysis programs include it in their tools  and you can also download standalone versions (Clustal W or Clustal X). 
22. [bookmark: _GoBack]Open Clustall Omega at http://www.ebi.ac.uk/Tools/msa/clustalo/
23. We are going to enter your trace sequences in Fasta format. This is a very simple format recognized by all DNA analysis programs. It is a greater than sign (>) followed by a file name and a hard return. The rest of the file is the sequence with soft returns. The > tells the program that the information on the first line is not sequence data.
24. In Step 1 change the protein to DNA
25. Type  >H600-T7 and press Enter (this makes a hard return)
26. Copy your sequence data from the H600-T7.txt file and paste it into the box in the web page then hit enter to make a hard return
27. Type H600-T3 and hit enter to make a hard return and paste in the H600-T3 data
-you have just created an alignment file with two sequences in it. You could have created a file using a text editor with many sequences, from two to thousands in it save it to your hard drive and uploaded it. 
28. Leave Step 2 Set your parameter set to Clustal w/o numbers
29. In Step 3 click submit
If you don’t have time or think the alignment will take a long time you can enter your email address and have the data sent to you.
30. The data will be presented as a text file with the aligned sequences and an indicator row below them. An asterisk in the indicator row means identity.
31. Note that both your traces agree perfectly. That isn’t usually the case. You can save either sequence and call it the consensus sequence.

Annotating a DNA Sequence

When you create a DNA file you should add information to it. If you look at a text file with just the sequence in it or a fasta file with just the title years later, it doesn’t mean much. I have tens of thousands of DNA sequences stored on my computer. When I created them I took the time to add a few important details so they aren’t meaningless, years later. For instance, one of the most useful things that can be added is “This data is no good”. We will use SnapGene Viewer to create a DNA sequence file in genbank (*.gb). This format is essentially a text file that allows a great deal of information to be included. Genbank files are recognized by all DNA analysis programs and can be opened in text editors or word processors.

1. Open SnapGene Viewer and select New DNA File
2. Open H600-T7.txt in a text editor and copy the DNA sequence to the clipboard
3. Paste the sequence into the box
-Another way to create the reverse complement sequence is by  simply checking the box, below and to the left.
4. Under Topology, make sure linear is selected
5. Select the detect common features box
6. Name the file H600-T7
-don’t worry about the .DNA suffix, that’s how SnapGene viewer likes to name files
7. Click OK and a new window will open showing a diagram of the DNA sequence with RE sites and common features. 
-since this is a very small sequence there aren’t any common features like orfs
8. Choose View > sequence
-note the tabs at the bottom left of the screen. These can be used to change the views as well
9. To save the file choose File > Save as, in the Save as Type box select Genbank standard. In the file name delete the .dna or it will be included in the file name and save the file in your directory of choice.
10. To annotate the sequence choose View > Description panel and another box will open
11. In the panel leave Natural DNA as is and don’t fill anything in the Source Organism
12. For sequence class choose viral, vrl
13. In the description box type “BaCMV OCOM4-37 genomic DNA”
14. In the comments box type, “HindIII fragment of genomic DNA, Good Sequence”
15. The accession number is a unique identifier that Genbank assigns. Leave it alone
16. Save the sequence. You will have to select Genbank Standard etc. again.
17. Close the sequence.
18. Open your test editor and look at the sequence now. It is now in Genbank format.
19. Download the BaCMV.gb file if you haven’t already and open it in SnapGene.
-This is a real genbank file. Try the different views and see the features. 
20. Close this file and SnapGene.


Searching GenBank using the BLAST algorithm

One of the first things scientists do when they generate finished DNA sequence is find out what is know about it. You can search the sequence for known motifs, or most commonly use the sequence to search GenBank and see if similar sequences are present there and if they have been described.

1. Open any of the H600 text or genbank files in SnapGene.
2. Copy your DNA sequence to the clipboard (in FASTA format) by Clicking Edit > Select All > Copy Restriction Fragment
3. Open Internet Explorer and go to “www.ncbi.nlm.nih.gov “.This will open the home page of the National Center for Biotechnology Information.
4. Open Blast and click on the BLAST (Basic Local Area Search Theorem) program.
	-this program is on the right side of the screen, under Popular Resources 
	Under Basic Blast is Nucleotide-nucleotide and there is  BLAST (blastn)
-this program allows you to compare you DNA sequences against all the sequences in the entire GenBank database
-A second program (BLASTX) will translate you DNA sequence in the 3 forward and 3 complementary reading frames and compare these 6 possible proteins to all the protein sequences in GenBank. BLASTX is more likely to detect homology as considerable DNA variation can occur and thus reduce homology without changing the amino acid composition.

5. Type > filename and hit enter to make a hard return
	-BLAST requires sequences in  in FASTA format

A sequence in FASTA format begins with a signal-line description, followed by lines of sequence data.  The description line is distinguished from the sequence data by a great-than (>) symbol in the first column. It is recommended that all lines of text be shorter than 80 characters in length.  An example sequence in FASTA format is:

>H600‑T3
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AAGCTTTGCCCGCTGCACCAAGACCGCTCATCAAGTCGTCCAGGCCCCTGAGATATGTAGGGACGGTGTCGAACACCTTTCCTTCCACGTGAACGACCCGTTGCTTGTAAGCGTTGAACTCTTGCATAATCTCTTCCAGATTGAAAACATTGCTGGCACGCAGTTCATCCTCGGAGTACAGTTCCAAAGC

6. Paste your sequence into the window.
7. Choose Search parameters
-under choose search set pick others
-under program selection choose somewhat similar sequences

8. Click search. A new screen will come up telling you when your results will be ready and formatted.
	-you are searching the non-redundant database of DNA sequences at GenBank
	-NOTE if you scroll farther down the screen you will see an option to have the search results 
9. Click the large Blast button and wait…and wait…and wait…
		-having the results emailed to me is my method of choice but that’s not allowed anymore
10. Eventually you will get a screen with a graphical interface that looks somewhat like this. 
[image: ]


With a lot of textual information below 

[image: ]

This (gi|12620808|gb|AF324835.1|AF324835) should be the first sequence you get.  The gb means this sequence was originally submitted to GenBank, emb would mean it was first in the European molecular biology database, dbj is a Japanese database. The big databases share sequences and update often.

AF324835 is the accession number.  This is the identifying code for the sequence.  Then comes the gene or DNA name. Finally is the score. If you used the T7 you probably got a score of 377, if you used the consensus you would get a score of 381. This is as good as it gets for DNA. It is identical.

11.	Click on the accession number and the DNA sequence will be displayed in GenBank format.  

12.	Click on Send (near the top right) select the clipboard and click add to clipboard and the sequence is added to the clipboard.  You can add many sequences to the clipboard.  BioEdit will open them all in one project.  This is very useful when collecting sequences from GenBank to align and analyze.
		-if you machine has been set to refuse cookies the clipboard will not work.
		-use send to file instead. I have been having problems with OSU security myself  

13.	You can save individual sequences by clicking Send>File>create file

You can select complete record and the type of format. It will ask you if you want to open it or save it to file. 

If you choose Save, it will open the Save As diaglog box. Pick a folder, give the sequence a name that makes sense and save it.  I always put the accession number in the sequence name.  

14.	Open the sequence in SnapGene and note all the annotation.

15.	Save the BLAST search.

16.	Now repeat the search but on the first page select Program>BLASTX instead of the default BLASTN.

17.	When you rerun the search notice how many more significant homology sequences are recovered. 

18.	Save the BLASTX results. 


Creating a Diagram of plasmid pH600 using pDraw

This is a simple DNA mapping and display program that is easy to use.  This program allows you to select specific enzymes.  It also allows you to build plasmids by combining different DNA sequences. Finally, it will allow you to choose restriction enzymes,cut your construct and show what it would look like if electrophoresed on an agarose gel. These advanced features will be addressed in a later Project.

1. You can enter DNA sequences into pDRAW several ways
2. To paste data in, start BioEdit, open the H600 consensus sequence and select H600.
3. Double-click on the title to bring up the DNA editing window.
4. Select the entire DNA sequence and copy to the clipboard
5. Start pDraw and click File>New>enter new sequence
		-this opens a text editing window
6. Paste your DNA sequence from the clipboard into the text window then press OK.
-the DNA sequence is mapped using the default settings which usually include the methylation sensitive residues and the RE recognition sequence
-If you open a sequence in pDRAW it is a very good idea to check the sequence by clicking Edit > Edit Sequence and inspecting the DNA. Sometimes the header is imported and you get bad data in the sequence
7. Save your sequence in the pDraw format (*.pdw).
-Save and save often
8. The default display setting is most of the RE’s and it also shows the RE recognition sites. A little too much clutter.  Let’s fix it.  Click Settings>plot> then check the explicitly selected enzymes only box and click apply. 
9. To add RE Sites to the diagram, cClick Settings>plot  then click the explicitly selected tab. Pick specific enzymes from the menu on the left. Note that the number of times each enzyme cuts the DNA is displayed. To select more than one enzyme hold down the Ctrl key. Click apply to show the desired sites. There aren’t many in the short 192 bp H600 sequence. (try HindIII)

10. This program will display a lot of information about a sequence.  Click View>Restriction Analysis for the RE data as a text file. This can be selected and pasted into a word processor or just printed.Hit View>Sequence and the DNA sequence is displayed. 



Data to be produced:

Computer files					
H600-T3.txt							 
H600-T7.txt
H600-T3 or H600-T7.gb  (annotated file)							
H600 consensus.gb 						 
H600 BLASTN search (2-3 pages) 				
H600 BLASTX search (2-3 pages)
H600.pdw
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